Umlaute in Dateinamen bei 1&1

Monday, December 12. 2011

 Das schöne an Standards ist ja, dass es soviele davon gibt... - also etwa Standards, wie die Umlaute des deutschen vercodete werden. Wer, wie ich, noch mit cp/m und 8.3-Dateinamen-Beschränkungen aufgewachsen ist, kommt vielleicht gar nicht auf die Idee, Umlaute in einen Dateinamen zu schreiben. Aber der Rest der Menschheit hat da weniger Skrupel.

Auf dem eigenen Rechner und binnen des gleichen OS/familie sieht alles ok aus und scheint zu klappen. Aber x-platform drohen die Bauchklatscher.

Eine Klientin hatte sich auf einer Seite ein Bildchen mit Hängematte eingefügt, und das Bild hiess auch genau so. Auf ihrem Windows - Laptop und mit ihrem GoLive schien das auch alles schön zu gehen, nur auf der www-Seite bei 1und1 war das Bild nicht zu sehen. Nachgeschaut per ftp und fireFtp zeigt den Umlaut in "Hängematte.jpg" auch klaglos im Listing der Dateien an. Aber jeder Versuch, die Datei zu loeschen, umzubenennen, zu verschieben scheitert mit 550, no such file.

1&1 stellt seinen homepage-Kunden ja noch ein Tool, den WebSite Explorer zur Verfügung. Darin nochmal versucht, der zeigt statt der Umlaute eine Raute mit Fragezeichen, rödelt eine Weile daran herum, aber dann gibt er sich "es ist ein Fehler aufgetreten" auch unverrichteter Dinge geschlagen. Nun schaden ein paar solche Dateileichen eigentllich nicht wirklich und stören in erster Linie nur meinen Ordnungssinn. Aber wenn der sich schon mal meldet...

Ok, so kriegt man die Dateileichen wieder weg: XP in einer vm starten, Netzwerklaufwerk verbinden, der Wizard fragt host (mit Protokoll eingeben!) und username ab, will noch das Passwort und öffnet das ftp-Verzeichnis brav als Unterordner der Netzwerkverbindungen im Windows Dateiexplorer. Hier werden die Dateinamen nun ohne den Umlaut dargestellt, also "Hngematte.jpg". Aber dieses schlechten Omens zum Trotz kann man hier die Dateien ohne Probleme ansprechen, wegmachen, was immer. Gelöst / solved

 

XP, IPv6 und die Browser

Friday, February 4. 2011

Auch als vm unter vbox eine windwos xp aufgesetzt bzw genauer: eine vmware-vmdk eingebunden und noch ein wenig aufgeräumt. Das ist ja nun wirklich ein sehr angenehmes Feature, dass man VirtuelleMaschinen anderer Formate so einfach einbinden kann. 
Das XP auf SP3 gebracht und dann mal nur zum Test IPv6 aktiviert:

Dazu geht man auf den Eigenschafts-Dialog der Netzwerkkarte und klickt auf hinzufuegen/Protokolle/IPv6.

Die Unterstuetzung fuer IPv6 ist aber scheints nicht ganz vollstaendig oder jedenfalls nicht so fugenlos wie mit Linux oder Windows 7. Von der Kommandozeile aus geht ein ping heise.de problemlos ueber IPv6, auch tracert bevorzugt IPv6. Aber Google Chrome erkennt den IPv6-Stack nicht und zeigt dual stack Webseiten nur per IPv4. Der MSIE6 dagegen überrascht mit IPv6-Fähigkeit. Und Firefox holt auf http://test-ipv6.com/ zweimal 10/10 Punkten. 

Also, geht doch. Nur die ISPs sind Vollversager .

(Page 1 of 1, totaling 2 entries)